Описание

Описание программы.

Программа Вавилон предназначена для работы с рекламными спонсорами. Её задача организовать рабочее место кликера и оптимизировать его работу по просмотру рекламных материалов.


Обзор интерфейса.

Главное окно программы имеет следующий вид:

Главное окно программы

Слева в верху находится выпадающий список групп спонсоров. В нем отображается активная на данный момент группа. Ниже находятся два списка, спонсоров и пользователей. В списке спонсоров находятся названия спонсоров. В списке пользователей - логины пользователей у выбраных спонсоров.

Далее, в центре сверху расположена панель инструментов по управлению программой. Кнопки имеют следующее назначение:

- Запуск просмотра в выделенных аккаунтах
- Запуск просмотра во всех аккаунтах
- Остановка просмотра в выделенных аккаунтах
- Остановка просмотра во всех аккаунтах
- Управление группами спонсоров
- Управление пользователями
- Управление чит-ссылками
- Переместить в группу...
- Добавить удалить спонсора
- Добавить пользователя
- Удалить пользователя
- Настройки программы
- Настройки аккаунтов
- Вызов справки
- Выход из программы
- За компьютером или нет

Под панелью управления находятся блоки с различной информацией по просмотру рекламных материалов.

Аккаунт. Здесь выводится информация по активному в данный момент аккаунту.

Таймер. Обычно рекламируемый сайт должен просмотреться некоторое количество времени. В данном блоке отображается количество секунд оставшееся до окончания просмотра.

Время. Здесь указывается время работы с момента запуска просмотра.

Информация просмотра. В этом блоке отображаются информация о ходе просмотра и различные элементы для действий пользователя во время просмотра. Например, здесь выводится капча, которую нужно распознать в ручную.

Под блоками информации располагается описание просматриваемой, в данный момент, ссылки. Еще ниже располагается окно браузера с рекламируемым, в данный момент, сайтом.


Работа с программой.

При запуске программа проходит авторизацию в клубе. Если авторизация прошла успешно, программа проверяет обновления. Если обновления есть, то она их загружает и запускается на работу.

Работу программы рассмотрим с использованием вымышленных спонсоров и логинов. Допустим мы зарегистрированы в таких проектах: bux1.ru, bux2.ru, bux3.ru, surf1.ru, surf2.ru и mail.ru. Во всех проеках, кроме mail.ru, мы зарегистрированы с логином vasya. В проектах bux1.ru, bux2.ru и surf1.ru у нас есть по второму аккаунту с логином petya. В проекте mail.ru мы зарегистрированны с логином yura.

Используя эти данные, переходим к настройке программы и её использованнию в просмотре рекламы.


Управление группами

Для удобства работы в программе предусмотрена возможность разделения спонсоров на группы. На свое усмотрение Вы можете распределить спонсоров на разные группы. Например, буксы можно поместить в группу под названием Буксы, почтовых спонсоров в группу Почтовики и т.д. Однако, чтобы перемещать спонсоров по разным группам, группы нужно вначале создать. Как это делать, описывается далее в этом разделе.

Выбрать активную группу можно выбором этой группы в выпадающем списке. Пример на рисунке.

В программе есть две стандартные группы, которые нельзя удалить. Это группы с названиями Все и Новые. В группе Все находятся все спонсоры, с которыми может работать программа. В группу Новые помещаются спонсоры, которые были недавно добавлены и загрузились с сервера во время обновления программы. Поэтому, рекомендую, проверять эту группу на появление новых спонсоров и перемещать этих спонсоров в другие группы, чтобы эта группа всегда была пустой. В этом случае Вы всегда сможете знать о новых спонсорах, которые были добавлены в программу. Также в группу Новые заносятся спонсоры из удаленных групп.

При выборе группы, в списке спонсоров отображаются спонсоры находящиеся в выбранной группе.

Для создания или удаления группы нажмите кнопку Управление группами спонсоров [image].

Появиться диалоговое окно:

Чтобы создать группу, в верхнем поле мы вводим название группы и нажимаем кнопку Добавить. Эта группа появляется в списке. Для удаления группы, группу нужно выбрать в списке групп и нажать кнопку Удалить.

В нашем примере мы создали три группы: Буксы, Серфинги и Почтовики. Для выхода нажмите кнопку Выйти.

Теперь нажав на выпадающий список групп, мы видим, что в списке появились добавленные нами группы.


Перемещение спонсоров из группы в группу

Для перемещения спонсоров из одной группы в другую, в списке спонсоров выделяем спонсоров, которые нужно переместить. Множественное выделение можно организовать используя клавиши Ctrl и Shift. Далее, нажимаем на кнопку Переместить в группу... . В появившемся окне выбираем группу, в которую хотим переместить спонсоров, и нажимем кнопку Переместить.

Перемещаем наших спонсоров по разным группам. bux1.ru, bux2.ru, bux3.ru в группу Буксы. surf1.ru, surf2.ru в Серфинги. mail.ru в Почтовики.

Результат перемещения можете понаблюдать, выбирая разные группы из выпадающего списка. Пример выбора группы Буксы видно на рисунке.


Управление пользователями.

Чтобы программа могла просматривать рекламу, нам нужно создать аккаунты. Аккаунт - это зарегистрированный у спонсора пользователь с определенным логином и паролем. У одного спонсора Вы можете быть зарегистрированны несколько раз с разными данными. В этом случае у этого спонсора Вы имеете несколько аккаунтов. Для создания аккаунта нам нужно две вещи: спонсор и пользователь. Первый у нас есть, т.к. он уже добавлен в программу разработчиком, второго нам нужно создать самим.

Для создания и удаления пользователей, нажмите кнопку Управление пользователями [image]. Появить диалоговое окно:

Для добавления пользователя, в полях Логин и Пароль введите данные пользователя, который у Вас зарегистрирован у какого-либо спонсора и нажмите кнопку Добавить. В нашем случае мы добавляем пользователей vasya, petya и yura. Поле Дополнительный пароль служит для добавления дополнительного пароля, который нужен для некоторых спонсоров. Например, у почтовика wmmail.ru существует пароль для операций. Этот пароль и нужно вводить в это поле.

Допустим Вы зарегистрированны в двух САР, и при этом логины одинаковы, но пароли разные. В этом случае нужно создать два пользователя, но чтобы не путаться в скобках сделать аписание. Как видно на рисунке у нас есть vasya и vasya(2). Описание может быть любым. Его цель сделать различие между одинаковыми логинами. Если у Вас где-то в логине используются скобки, то в конце логина обязательно пропишите скобки, можно без коментария. Например, va(sya().

Для удаления пользователя, выберите его в списке и нажмите кнопку Удалить.

Для выхода нажмите кнопку Выйти.

Теперь у нас есть все, чтобы создать аккаунт. Как создавать аккаунты написано в следующем разделе.


Создание и удаление аккаунтов.

Создание аккаунта - это добавление пользователя к спонсору. Чтобы добавить пользователя к спонсору, выделите нужных спонсоров в списке спонсоров и нажмите кнопку Добавить пользователя [image].

В появившемся окне, выберите нужного пользователя и нажмите кнопку Добавить.

Для выхода нажмите кнопку Выйти.

Добавьте пользователей в соответсвии с нашим примером.

Теперь при выборе в списке спонсоров спонсора, в списке пользователей появляются пользователи, которые принадлежат этому спонсору. Выберите группу Все и выделите всех спонсоров. В списке пользователей Вы увидите следующее:

Как Вы видите появились все созданные нами аккаунты. Чтобы понять какой пользователь принадлежит к какому спонсору, наведите на пользователя курсор и во всплывающей подсказке появиться имя спонсора, к которому принадлежит данный пользователь.

Чтобы удалить аккаунт, в списке пользователей выберите пользователя и нажмите на кнопку Удалить пользователя [image]. Аккаунт будет удален.


Добавление и удаление спонсоров.

Беря во внимание тот факт, что многие спонсоры недолговечны, в программе предусмотрина возможность удаления и добавления спонсоров. Эта функциональность также полезна, если Вы решили не работать с каким-либо спонсором. Для удаления или добавления спонсора нажмите на кнопку Добавление и удаление спонсора [image]. Появиться диалоговое окно:

Для удаления спонсора нажмите кнопку Текущие. При этом активизируется кнопка Удалить и в списке появяться все спонсоры, которые на данный момент у Вас в программе. Выберите спонсора и нажмите кнопку Удалить. Спонсор полностью удалиться из программы и также удалиться файл настроек спонсора.

Если Вы решили возобновить работу с ранее удаленным спонсором, Вам нужно получить файл настроек этого спонсора. Для этого нажмите кнопку Загрузить. В списке появяться файлы спонсоров, которые есть на сервере, но которых нет у Вас. Выберите нужный файл и нажмите кнопку Добавить. При этом с сервера будет загружен выбраный файл и спонсор добавиться в программу.


Управление чит-ссылками.

Практически у всех спонсоров есть ловушки для автокликеров. Это так называемые чит-ссылки, скрытые ссылки и др. Программа Вавилон сделана таким образом, чтобы не попадаться на эти ловушки. Вчастности в программу встроена защита от скрытых ссылок, а также мощная защита от любых чит-ссылок. При определенных настройках (это описывается в разделе Настройки аккаунта) Вы можете себя обезопасить от чит-ссылок на 100%. В эту защиту входит общая база чит-ссылок, которая храниться на сервере разработчика программы Вавилон. Эту базу формируют сами пользователи программы.

Формирование базы происходит одновременно с созданием списка чит-ссылок у себя в программе. Для создания списка чит-ссылок нажмите на кнопку Управление чит-ссылками [image]. Откроется окно:

Чтобы добавить чит-ссылку в список, введите ее в верхнее поле и нажмите кнопку Добавить. В этом случае чит-ссылка будет добавлена в список и отправлена на сервер. Если такой чит-ссылки на сервере нет, она будет добавлена в базу чит-ссылок.

Для удаления чит-ссылки из списка, выберите чит-ссылку в списке и нажмите на кнопку Удалить. Чит-ссылка будет удалена со списка. Однако, при удалении чит-ссылки из списка с базы на сервере чит-ссылка не удаляется. Удаление чит ссылки на сервере произойдет, когда пять пользователей удалят ее у себя в программе.

Вы также можете получить новые чит-ссылки, которые появились на сервере, нажав на кнопку Обновить.

Если Вы хотите получить все чит-ссылки, находящиеся в базе на сервере, нажмите кнопку Загрузить.


Настройки программы.

Для настройки опций программы, нажмите кнопку Настройки программы [image]. Появиться окно настроек программы:

В этом окне Вы можете выставить следующие опции программы.

Данные для авторизации в клубе. Здесь Вы прописываете свой WMID и пароль, с которым зарегистрированы в клубе кликольщиков.

Запускаться в трее. При старте программа будет сворачиваться в трей.

Автоматически переходить к следующему распознаванию. Эта опция связана с автоматическим переходом к ручному распознаванию. Допусти Вы запустили несколько спонсоров на просмотр и активным остался bux1.ru. Вся информация в программе выводится об этом спонсоре. Но у спонсора bux2.ru программа не смогла распознать капчу и требуется ручное вмешательство. Если эта опция включена, программа автоматически сделает bux2.ru активным. Если же эта опция отключена, bux2.ru нужно будет выбрать в ручную для дальнейшего распознавания.

Заголовок имитируемого браузера. Здесь Вы должны вставить заголовок браузера, в котором Вы заходите на сайты спонсоров. Для чего это нужно? Многие спонсоры регистрируют с какого браузера заходит пользователь. И если пользователь заходит вывести деньги или еще что-нибудь сделать с одного браузера, а просматривает ссылки в другом, это вызывает подозрение админов САР. Поэтому Вам нужна полная имитация Вашего браузера.

Получить заголовок браузера не сложно. Если Ваш браузер, в котором Вы постоянно просматриваете сайты спонсоров, в системе стоит как браузер по умолчанию, то просто кликните по ссылке Получить заголовок браузера. Ваш браузер откроет страницу, где будет указан заголовок Вашего браузера. Скопируйте этот заголовок со страницы и вставьте в поле Заголовок имитируемого браузера в свойствах программы. Если Ваш браузер не установлен в системе по умолчанию, просто зайдите в нем по адресу http://club.bymagic.ru/useragent.php и Вы попадете на туже страницу с заголовком Вашего браузера.

Следующие две установки связаны с обрывами связи. Если у Вас оборвется связь или на сервере спонсора будут проблемы программа повторно будет восстанавливать связь столько раз, сколько указано в Количество обновлений соединения. Промежуток между попытками восстановить связь указывается в секундах. Обычно обрывы часто бывают при работе через прокси-сервер.


Настройки аккаунтов.

Для установки опций аккаунтов, нажмите кнопку Настройки аккаунтов [image]. Появиться окно настроек аккаунтов.

В левой половине окна находится список всех созданых Вами аккаунтов. В этом списке Вы выбираете аккаунты, которые хотите настроить. Можно выбирать как один, так и несколько аккаунтов. Устанавливаемая опция будет применена к выделенным аккаунтам. Если Вы хотите установить какую-либо опцию для всех аккаунтов, установите галочку Применить для всех.

В правой половине расположены устанавливаемые для выбраных аккаунтов опции.

Запускать просмотр при старте программы. При установленной этой опции программа будет запускать на просмотр данный аккаунт.

Использовать прокси-сервер. Для данного аккаунта будет использоваться прокси-сервер. Чтобы программа имела возможность использовать прокси-сервер, в папке, где находится программа нужно разместить файл со списком прокси-серверов с именем proxy.txt. Формат записей следующий, каждый прокси с новой строки, после IP-адреса через двоеточие идет порт. Пример на рисунке:

Изменить IP по окончанию сайтов. Некоторые спонсоры во время серфинга по окончании сайтов, если сменить IP-адрес, дают на просмотр еще дополнительные сайты. При установленной опции программа по окончании сайтов в серфинге меняет IP. Грубо говоря в этом случае программа начинает работать через прокси-сервер.

Просматривать рекламируемый сайт. Если установлена эта опция, то программа загружает рекламируемый сайт в браузере. Совет. Если Вы не хотите страдать от вирусов и разных выскакивающих окон, снемите эту опцию.

Просматривать ссылки перед серфингом. Эта опция связана с безопасность просмотра. При установленой опции, перед просмотром ссылок Вам будет предложено просмотреть список ссылок. В списке Вы можете отметить ссылки, которые не хотите просматривать. В этом случае эти ссылки быдут добавлены с список чит-ссылок у Вас на компьютере и в базу на сервере. При просмотре ссылок перед просмотром рекламы Вы можете себя обезопасить на 100%. Данная опция сделана в основном для букс-систем.

Интервал обновлений. Здесь устанавливается интервал обновлений когда заканчиваются рекламные ссылки. Программа вычисляет случайный интервал между заданными минимальным и максимальным значениями. Интервал задается в секундах. Минимальный интервал, который можно установить равен 30 секундам. Если минимальный интервал установить равным 0, программа по окончании ссылок завершит просмотр.

Обновление капчи. Если программа не смогла распознать капчу, она дополнительно загружает ее столько раз сколько указано в поле или пока не распознает.

Последнии опции связаны с просмотром. Если они установлены, то программа будет просматривать ссылки в письмах, серфинге и автосерфинге. Эта опция была сделана из-за JetSwap. У этого спонсора своя программа для серфинга и замаскироваться под нее нет возможности. Поэтому через SafeSurf можно серфить, а через Вавилон просматривать почту. В этом случае опции Автосерфинг и Серфинг нужно отключить.


Запуск и остановка просмотра

Для запуска одного или нескольких аккаунтов, выбирите нужные в списке пользователей и нажмите кнопку Запуск просмотра в выделенных аккаунтах [image]. Если хотите запустить все аккаунты, которые у Вас есть, нажмите кнопку Запуск просмотра во всех аккаунтах [image].

Во время работы просмотра в поле Информация просмотра выводится разная информация о просмотре, по которой Вы сможете определить действия программы в данный момент.

В некоторых случаях для продолжения просмотра нужно ручное вмешательство пользователя. Это может быть связано с просмотром ссылок перед серфингом или когда программа сама не смогла распознать капчу. В этом случае в списках спонсор и пользователь помечаются красными значками, чтобы было видно какой аккаунт нужно выбрать для дальнейших действий. Если у Вас в опциях программы установлена опция Автоматически переходить к следующему распознаванию, программа сама сделает этот аккаунт активным и в ручном выборе не будет надобности.

Если в настройках аккаунта у Вас установлена опция Просматривать ссылки перед серфингом, перед просмотром ссылок в букс-системах появится предложение просмотреть ссылки. Пример на рисунке:

Если Вы не хотите просматривать список ссылок, нажмите кнопку Отмена. Для просмотра списка - кнопку Просмотр. При нажатии на Просмотр появиться окно со списком ссылок.

В этом окне Вы можете снять отметку с любой ссылки. В этом случае данная ссылка будет помечена как чит-ссылка, и будет занесена в список и базу чит-ссылок. Такая ссылка просматриваться не будет. Для подтверждения отмеченых ссылок, нажмите ОК. Если Вы нажмете кнопку Отмена, все действия по отмечиванию ссылок будут отменены.

Предложение о просмотре ссылок может возникнуть еще при следующей ситуации, даже если опция Просматривать ссылки перед серфингом не включена. Программа запоминает у какого спонсора какая чит-ссылка. Если при просмотре программа не нашла такую чит-ссылку, потому-что спонсор ее изменил, программа сама просмотрит список чит-ссылок. Если она не найдет подходящей, выдаст запрос на ручной просмотр ссылок перед серфингом.

Если программа не смогла распознать капчу, она передаст ее для ручного распознавания. Ручное распознавание может быть нескольких видов:

  1. Выбрать нужный элемент на картинке и кликнуть по нему
  2. В поле ввода ввести символы с картинки
  3. Выбрать один из вариантов, изображенный на картинке

На рисунке показан пример выбора одного из вариантов.

Ручное распознавание капчи не должно вызвать затруднений. Все действия похожи с действиями на сайте спонсора и интуитивно понятны.

Если Вы не хотите распознавать данную капчу, нажмите кнопку Пропустить. Программа пропустит эту ссылку и перейдет к другой.

Чтобы не следить за появлением сообщений о ручных действиях, Вы можете свернуть программу в трей и заниматься своими делами. Когда нужно будет ручное вмешательство пользователя, программа выведет окно над треем с такой же информацией как и в блоке Информация просмотра. Пример на рисунке:

Если при появлении такого окна Вы хотите развернуть главное окно программы, нажмите кнопку Главное.

По окончанию ссылок программа переходит в ожидание, если у Вас задан интервал обновлений. Если интервал не задан, программа закончит просмотр.

Если во время просмотра Вам нужно будет отойти от компьютера, но процесс просмотра Вы останавливать не хотите, то нажмите на кнопку За компьютером или нет [image]. В этом случае программа будет пропускать просмотры, в которых нужно ручное вмешательство.

Чтобы остановить просмотр в одном или нескольких аккаунтах, выделите эти аккаунты в списке пользователей и нажмите кнопку Остановка просмотра в выделенных аккаунтах [image]. Если хотите остановить просмотр во всех аккаунтах, нажмите кнопку Остановка просмотра во всех аккаунтах [image].